Thursday, 18 June 2009

concordance now in Debian NEW queue!


For those interested, my efforts to package concordance and congruity, the CLI and GUI tools to configure a Logitech Harmony remote are finally starting to pay off!

concordance has been accepted from the Debian-mentors repo and uploaded to the Debian NEW queue! Big thanks to Patrick Matthäi for his guidance.

That said, it means that concordance will hopefully soon also be in Ubuntu. (and it was also in REVU. Thanks to all those who reviewed it and posted comments. They were all very helpful.)

Now, I'm still having some issues packaging the newest version of congruity, or more precisely getting an error in the package after it's installed. Something that I believe is related to python-wxgtk2.8-0, about 'AttributeError: 'BoxSizer' object has no attribute 'AddStretchSpacer''. I just haven't had much luck it finding out what dependency I had wrong or missing...

Fortunately, the packages are also very much reachable in case you want to try them: check out my PPA, at

1 comment:

Whytey said...

Congrats Matt.

It is great to not have to use Windows to update my Harmony remote. I greatly appreciate your work and look forward to seeing the packages in the official Ubuntu repos.